Wednesday, February 15, 2012

HUAWEI Mobile Broadband dongle not working on Ubuntu ? Try Mobile partner on Ubuntu

Today I noticed that, I can’t connect to the Internet using my HUAWEI E153 dongle on Ubuntu 11.10. (In the afternoon, it was working well on Ubuntu). 

In Network connection menu in the Notification area, it shows my mobile connection plan (Which I configured earlier; that means my dongle was detected by Ubuntu), but when I select it, it didn't connect to the Internet. 
I tried it several times and tried several things( unplugged and-replugged etc.) and but unable to fix it. Then I moved to my old-friend windows and googled about the problem. Observed many people have similar questions.

Mobile partner software for Linux

Most important thing which I found was “Mobile partner software for Linux”. I downloaded and installed it. (installation is very straightforward, Read readme.txt for installation instructions. )

I unplugged the dongle and re-plugged it.
 
Wow, Mobile partner application automatically stared. After few seconds it showed the signal strength at left bottom corner. Then I created a new profile (configured APN and Save) and pressed connect button. 

It connected to the Internet. At last... :)



But when you are using mobile partner even you are connected to the Internet it will be shown as you aren't connect.

Don’t forget: Now you can send SMSs and read SMS using mobile partner on Ubuntu. :) But the network statistics wasn't working properly in my system.   :(


Note:   I have updated the downloaded link.

New Download location: http://www.mediafire.com/?7a0aa7414cud40h
To old Download location: click here